using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[?(new|evo|bug|wf)(?:[^0-9]{0,5}(?<!op)(?<!op )([0-9]{5,}))? ?-?_?\|?\]? ?";
string input = @"EVO156484 - ajout avec solde PRI (O/N)
EVO158604 - [GC] Ajout gestion type transport hors moisson
Evo158595 [676M] - OP19068 Integration factures Immo et
Evo158595 [676M] - OP 19068 Integration factures Immo et
Evo OP19068 Integration factures Immo et
Evo OP 19068 Integration factures Immo et
158595 - 676M - OP19068 Integration factures Immo et creat
BUG 160585 Interdire la saisie des temps sur le mois après
BUG-[DSN] Implementation bloc 42 pour CVAE
BUG153922-[DSN] Resolution pb bloc signataire/creation
BUGXXXXXX - [GC] passer entete.zon-int-4 a 0
BUG159220 - En MODEXP si modif Mode reg et mt reg ne
BUG - Ensi 159220 et
Bug888888 - [EMI] retouche pour le window.close
BUG159417 - [GC][MNT157789] Correction controle phyto saisi
[DSN][GRH][WF160820] PB sur les libelles des Types et codes
Evo157633 - 560- OP19043 - Mise à disposition d'une extract
Evo157633 - 560 - OP19043 - Extraction complete de mouvemen
BUG|159471|Calcul des % d'avancement totaux facture dièses
160112 TDB3 ajout diese 52 et 53 reste a receptionner et su
BUG156820 #43 du type port avec enlevement client chargé qu
BUG156820_#43 du type port avec enlevement client chargé qu
BUG 153322suite L'engagé est un BTE composé des CDF non réc";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}