import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[?(new|evo|bug|wf)(?:[^0-9]{0,5}(?<!op)(?<!op )([0-9]{5,}))? ?-?_?\\|?\\]? ?";
final String string = "EVO156484 - ajout avec solde PRI (O/N)\n"
+ "EVO158604 - [GC] Ajout gestion type transport hors moisson\n"
+ "Evo158595 [676M] - OP19068 Integration factures Immo et\n"
+ "Evo158595 [676M] - OP 19068 Integration factures Immo et\n"
+ "Evo OP19068 Integration factures Immo et\n"
+ "Evo OP 19068 Integration factures Immo et\n"
+ "158595 - 676M - OP19068 Integration factures Immo et creat\n"
+ "BUG 160585 Interdire la saisie des temps sur le mois après\n"
+ "BUG-[DSN] Implementation bloc 42 pour CVAE\n"
+ "BUG153922-[DSN] Resolution pb bloc signataire/creation\n"
+ "BUGXXXXXX - [GC] passer entete.zon-int-4 a 0\n"
+ "BUG159220 - En MODEXP si modif Mode reg et mt reg ne\n"
+ "BUG - Ensi 159220 et\n"
+ "Bug888888 - [EMI] retouche pour le window.close\n"
+ "BUG159417 - [GC][MNT157789] Correction controle phyto saisi\n"
+ "[DSN][GRH][WF160820] PB sur les libelles des Types et codes\n"
+ "Evo157633 - 560- OP19043 - Mise à disposition d'une extract\n"
+ "Evo157633 - 560 - OP19043 - Extraction complete de mouvemen\n"
+ "BUG|159471|Calcul des % d'avancement totaux facture dièses\n"
+ "160112 TDB3 ajout diese 52 et 53 reste a receptionner et su\n"
+ "BUG156820 #43 du type port avec enlevement client chargé qu\n"
+ "BUG156820_#43 du type port avec enlevement client chargé qu\n"
+ "BUG 153322suite L'engagé est un BTE composé des CDF non réc";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}