// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)(\<)([A-Za-z0-9_!]+)(.*?)(\>)").unwrap();
  let string = "<html>
<body>
<h1>Aqui cabeçalho do arquivo</h1>
<p>Meu parágrafo da página web.</p>
<p>Meu segundo parágrafo.</p>
</body>
</html>
<p>
<html></html>
<!DOCTYPE>
<input href=\"\"/>
<button type=\"submit\"></button>
<button></button>
Aenean lacinia bibendum <a href=\"/life\">life</a> sed consectetur. <a href=\"/work\">Work</a> quis risus eget urna mollis ornare <a href=\"/about\">about</a> leo.
<br/>";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}