$re = '/((?:\.|^).)?.(?=.*@)/m';
$str = 'captain.am-e-r-ica@email.com
my-cutie.pie+here@email.com
tom.cat@email.com
cutie.pie@email.com
captain.america@email.com';
$subst = "$1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;