import re
regex = re.compile(r"((?:\.|^).)?.(?=.*@)", flags=re.MULTILINE)
test_str = ("captain.am-e-r-ica@email.com\n"
"my-cutie.pie+here@email.com\n"
"tom.cat@email.com\n"
"cutie.pie@email.com\n"
"captain.america@email.com")
subst = "$1*"
result = regex.sub(subst, test_str)
if result:
print(result)