re = /((?:\.|^).)?.(?=.*@)/m
str = 'captain.am-e-r-ica@email.com
my-cutie.pie+here@email.com
tom.cat@email.com
cutie.pie@email.com
captain.america@email.com'
subst = '$1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result