import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[fF]iles\\b[^*()]*(?:\\([^()]*\\))?\\|\\*(?<ext>\\.[\\w*]+)(?:[,;]\\*(?<ext>\\.[\\w*]+))*";
final String string = "txt files `(*.txt)|*.txt|All files (*.*)|*.*`\n"
+ "Image Files`|*.jpg;*.jpeg;*.png;`\n"
+ "Excel Files `(*.xls, *.xlsx)|*.xls;*.xlsx|CSV Files (*.csv)|*.csv`";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}