const regex = new RegExp('\\b[fF]iles\\b[^*()]*(?:\\([^()]*\\))?\\|\\*(?<ext>\\.[\\w*]+)(?:[,;]\\*(?<ext>\\.[\\w*]+))*', 'g')
const str = `txt files \`(*.txt)|*.txt|All files (*.*)|*.*\`
Image Files\`|*.jpg;*.jpeg;*.png;\`
Excel Files \`(*.xls, *.xlsx)|*.xls;*.xlsx|CSV Files (*.csv)|*.csv\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}