package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/backup/(ABC|ABD)$`)
var str = `/backup/ABC
/backup/ABD
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}