$re = '~/backup/(ABC|ABD)$~m';
$str = '/backup/ABC
/backup/ABD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);