import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\x3b\\x3b[a-zA-Z0-9]{4,}_[A-F0-9]{4,}\\x3b\\x3b\\/.[a-z]{2,}\\/\\x2e$";
final String string = "yowser/2.5 safari/537.36;;NLSRPE_A99D3FFC;;/.juvenile/.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}