re = /\x3b\x3b[a-zA-Z0-9]{4,}_[A-F0-9]{4,}\x3b\x3b\/.[a-z]{2,}\/\x2e$/
str = 'yowser/2.5 safari/537.36;;NLSRPE_A99D3FFC;;/.juvenile/.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end