#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d+\s*(?:lac|crs?|k)\b\.?"
Local $sString = "65 lac this is 55 lac. and more price 100 lac. randome text to test price45 crs. and 65 cr and to test its matching rs 3244 k like rs 55k. to its matchibg 65 cr. but not 65 cr als not matching price 123 lac more of it 55 crs." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"65 lacthis is 55 lacand more" & @CRLF & _
"" & @CRLF & _
"it should not match this65 lac and this 55 lac and this87lac" & @CRLF & _
"" & @CRLF & _
"it should not match this65 lac and this 55 lacand this87lacdsdsa" & @CRLF & _
"" & @CRLF & _
"should match 76 lac. nd 7 cr. including . It shoudl match 78 lac and 74 crs as well"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")