re = /\b\d+\s*(?:lac|crs?|k)\b\.?/m
str = '65 lac this is 55 lac. and more price 100 lac. randome text to test price45 crs. and 65 cr and to test its matching rs 3244 k like rs 55k. to its matchibg 65 cr. but not 65 cr als not matching price 123 lac more of it 55 crs.
65 lacthis is 55 lacand more
it should not match this65 lac and this 55 lac and this87lac
it should not match this65 lac and this 55 lacand this87lacdsdsa
should match 76 lac. nd 7 cr. including . It shoudl match 78 lac and 74 crs as well'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end