import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+\\s*(?:lac|crs?|k)\\b\\.?";
final String string = "65 lac this is 55 lac. and more price 100 lac. randome text to test price45 crs. and 65 cr and to test its matching rs 3244 k like rs 55k. to its matchibg 65 cr. but not 65 cr als not matching price 123 lac more of it 55 crs.\n\n\n"
+ "65 lacthis is 55 lacand more\n\n"
+ "it should not match this65 lac and this 55 lac and this87lac\n\n"
+ "it should not match this65 lac and this 55 lacand this87lacdsdsa\n\n"
+ "should match 76 lac. nd 7 cr. including . It shoudl match 78 lac and 74 crs as well";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}