const regex = /On-Demand Color:\s(\S+)\n.*\n.*\n.*\n.*\n.*Liveness-detection: Enabled/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('On-Demand Color:\\s(\\S+)\\n.*\\n.*\\n.*\\n.*\\n.*Liveness-detection: Enabled', 'gm')
const str = `RA#show segment-routing traffic-eng on-demand color detail | utility egrep Color -B 10
Sat Dec 25 11:24:22.891 JST
SR-TE On-Demand-Color database
------------------------
On-Demand Color: 20
--
Performance-measurement:
Reverse-path Label: Not Configured
Delay-measurement: Disabled
Liveness-detection: Enabled 《-------
Profile: liveness1
Invalidation Action: down
Logging:
Session State Change: Yes
Per-flow Information:
Default Forward Class: 0
On-Demand Color: 23
--
Performance-measurement:
Reverse-path Label: Not Configured
Delay-measurement: Disabled
Liveness-detection: Enabled 《--------
Profile: liveness1
Invalidation Action: down
Logging:
Session State Change: Yes
Per-flow Information:
Default Forward Class: 0
On-Demand Color: 301`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}