$re = '/On-Demand Color:\s(\S+)\n.*\n.*\n.*\n.*\n.*Liveness-detection: Enabled/m';
$str = 'RA#show segment-routing traffic-eng on-demand color detail | utility egrep Color -B 10
Sat Dec 25 11:24:22.891 JST
SR-TE On-Demand-Color database
------------------------
On-Demand Color: 20
--
Performance-measurement:
Reverse-path Label: Not Configured
Delay-measurement: Disabled
Liveness-detection: Enabled 《-------
Profile: liveness1
Invalidation Action: down
Logging:
Session State Change: Yes
Per-flow Information:
Default Forward Class: 0
On-Demand Color: 23
--
Performance-measurement:
Reverse-path Label: Not Configured
Delay-measurement: Disabled
Liveness-detection: Enabled 《--------
Profile: liveness1
Invalidation Action: down
Logging:
Session State Change: Yes
Per-flow Information:
Default Forward Class: 0
On-Demand Color: 301';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);