// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)On-Demand Color:\s(\S+)\n.*\n.*\n.*\n.*\n.*Liveness-detection: Enabled").unwrap();
let string = "RA#show segment-routing traffic-eng on-demand color detail | utility egrep Color -B 10
Sat Dec 25 11:24:22.891 JST
SR-TE On-Demand-Color database
------------------------
On-Demand Color: 20
--
Performance-measurement:
Reverse-path Label: Not Configured
Delay-measurement: Disabled
Liveness-detection: Enabled 《-------
Profile: liveness1
Invalidation Action: down
Logging:
Session State Change: Yes
Per-flow Information:
Default Forward Class: 0
On-Demand Color: 23
--
Performance-measurement:
Reverse-path Label: Not Configured
Delay-measurement: Disabled
Liveness-detection: Enabled 《--------
Profile: liveness1
Invalidation Action: down
Logging:
Session State Change: Yes
Per-flow Information:
Default Forward Class: 0
On-Demand Color: 301";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}