#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!\A)|^(?!.*\.join\.))(.*?)PD_"
Local $sString = "it.mycompany.db.beans.str1.PD_T_PD_CLASS" & @CRLF & _
"it.mycompany.db.beans.join.PD_T_CLASS" & @CRLF & _
"it.mycompany.db.beans.str2.PD_T_CLASS_1" & @CRLF & _
"it.mycompany.db.beans.join.PD_T_CLASS_1" & @CRLF & _
"PD_T_CLASS myVar = new PD_T_CLASS();" & @CRLF & _
"myVar.setPD_T_CLASS(something);"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)