#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xsmJ)(?:(?<=\n)|(?<=\A)) # Necessarily at the begining of a new line or start of string" & @CRLF & _
"(?<leading_space>[ ]{0,3})" & @CRLF & _
"(?<tag_all>" & @CRLF & _
" (?:" & @CRLF & _
" (?<div_open>" & @CRLF & _
" <(?<tag_name>\S+)" & @CRLF & _
" (?<tag_attributes>(?&tag_attr))*" & @CRLF & _
" [^\>]*" & @CRLF & _
" >\n*" & @CRLF & _
" )" & @CRLF & _
" (?<content>.+?)" & @CRLF & _
" \n*" & @CRLF & _
" (?<div_close>" & @CRLF & _
" (?(<leading_space>) # If leading spaces were found" & @CRLF & _
" (?:" & @CRLF & _
" (?<=\n)\g{leading_space} # Either there is a symmetry in leading space for open and closing tag" & @CRLF & _
" |" & @CRLF & _
" (?:(?<=\S)[[:blank:]\h]*) # or the closing tag is on the same line with preceding data" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (?=<\/\g{tag_name}>) # No leading space, so we don't expect anything before the closing tag other than what has already been caught in the 'content'" & @CRLF & _
" )" & @CRLF & _
" <\/\g{tag_name}>" & @CRLF & _
" )" & @CRLF & _
" [[:blank:]\h]*\n" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" <!--[[:blank:]\h\v]*(?<html_comment>.*?)[[:blank:]\h\v]*-->" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" <" & @CRLF & _
" [[:blank:]\h\v]*" & @CRLF & _
" (?<tag_name>[a-zA-Z0-9][\w\-]+)" & @CRLF & _
" (?<tag_attributes>(?&tag_attr))*" & @CRLF & _
" [[:blank:]\h\v]*" & @CRLF & _
" \/?" & @CRLF & _
" [[:blank:]\h\v]*" & @CRLF & _
" >" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"(?(DEFINE)" & @CRLF & _
" (?<tag_attr>" & @CRLF & _
" (?:" & @CRLF & _
" [[:blank:]\h]*" & @CRLF & _
" [\w\-]+" & @CRLF & _
" [[:blank:]\h]*" & @CRLF & _
" =" & @CRLF & _
" [^\"\'[:blank]\h]+" & @CRLF & _
" [[:blank:]\h]*" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" [[:blank:]\h]*" & @CRLF & _
" [\w\-]+" & @CRLF & _
" [[:blank:]\h]*" & @CRLF & _
" =" & @CRLF & _
" [[:blank:]\h]*" & @CRLF & _
" (?<quote>["'])" & @CRLF & _
" (.*?)" & @CRLF & _
" \g{quote}" & @CRLF & _
" [[:blank:]\h]*" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
")"
Local $sString = "<abbr title="`first backtick!">SB</abbr> " & @CRLF & _
"" & @CRLF & _
"<abbr title="`second backtick!">SB</abbr>" & @CRLF & _
"" & @CRLF & _
"<table>" & @CRLF & _
"<tr><td markdown="block">test _emphasis_ (block)</td></tr>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"## More complicated" & @CRLF & _
"" & @CRLF & _
"<table>" & @CRLF & _
"<tr><td markdown="1">" & @CRLF & _
"* this is _not_ a list item</td></tr>" & @CRLF & _
"<tr><td markdown="span">" & @CRLF & _
"* this is _not_ a list item</td></tr>" & @CRLF & _
"<tr><td markdown="block">" & @CRLF & _
"* this _is_ a list item" & @CRLF & _
"</td></tr>" & @CRLF & _
"</table>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")