$re = '/(?:(?<=\n)|(?<=\A)) # Necessarily at the begining of a new line or start of string
(?<leading_space>[ ]{0,3})
(?<tag_all>
(?:
(?<div_open>
<(?<tag_name>\S+)
(?<tag_attributes>(?&tag_attr))*
[^\>]*
>\n*
)
(?<content>.+?)
\n*
(?<div_close>
(?(<leading_space>) # If leading spaces were found
(?:
(?<=\n)\g{leading_space} # Either there is a symmetry in leading space for open and closing tag
|
(?:(?<=\S)[[:blank:]\h]*) # or the closing tag is on the same line with preceding data
)
|
(?=<\/\g{tag_name}>) # No leading space, so we don\'t expect anything before the closing tag other than what has already been caught in the \'content\'
)
<\/\g{tag_name}>
)
[[:blank:]\h]*\n
)
|
(?:
<!--[[:blank:]\h\v]*(?<html_comment>.*?)[[:blank:]\h\v]*-->
)
|
(?:
<
[[:blank:]\h\v]*
(?<tag_name>[a-zA-Z0-9][\w\-]+)
(?<tag_attributes>(?&tag_attr))*
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
>
)
)
(?(DEFINE)
(?<tag_attr>
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[^\"\'[:blank]\h]+
[[:blank:]\h]*
)
|
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[[:blank:]\h]*
(?<quote>["\'])
(.*?)
\g{quote}
[[:blank:]\h]*
)
)
)/xsmJ';
$str = '<abbr title="`first backtick!">SB</abbr>
<abbr title="`second backtick!">SB</abbr>
<table>
<tr><td markdown="block">test _emphasis_ (block)</td></tr>
</table>
## More complicated
<table>
<tr><td markdown="1">
* this is _not_ a list item</td></tr>
<tr><td markdown="span">
* this is _not_ a list item</td></tr>
<tr><td markdown="block">
* this _is_ a list item
</td></tr>
</table>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);