import Foundation
// WARNING: You included a flag that Swift doesn't support: J
// Wehn this flag is set, it allows duplicated capturing group names.
// By default, Swift captures only the last value matched for a repeated capture group.
// As an alternative, the pattern can be modified to contain one capturing group per group you want to get in the result.
let pattern = ##"""
(?:(?<=\n)|(?<=\A)) # Necessarily at the begining of a new line or start of string
(?<leading_space>[ ]{0,3})
(?<tag_all>
(?:
(?<div_open>
<(?<tag_name>\S+)
(?<tag_attributes>(?&tag_attr))*
[^\>]*
>\n*
)
(?<content>.+?)
\n*
(?<div_close>
(?(<leading_space>) # If leading spaces were found
(?:
(?<=\n)\g{leading_space} # Either there is a symmetry in leading space for open and closing tag
|
(?:(?<=\S)[[:blank:]\h]*) # or the closing tag is on the same line with preceding data
)
|
(?=<\/\g{tag_name}>) # No leading space, so we don't expect anything before the closing tag other than what has already been caught in the 'content'
)
<\/\g{tag_name}>
)
[[:blank:]\h]*\n
)
|
(?:
<!--[[:blank:]\h\v]*(?<html_comment>.*?)[[:blank:]\h\v]*-->
)
|
(?:
<
[[:blank:]\h\v]*
(?<tag_name>[a-zA-Z0-9][\w\-]+)
(?<tag_attributes>(?&tag_attr))*
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
>
)
)
(?(DEFINE)
(?<tag_attr>
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[^\"\'[:blank]\h]+
[[:blank:]\h]*
)
|
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[[:blank:]\h]*
(?<quote>["'])
(.*?)
\g{quote}
[[:blank:]\h]*
)
)
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = ###"""
<abbr title="`first backtick!">SB</abbr>
<abbr title="`second backtick!">SB</abbr>
<table>
<tr><td markdown="block">test _emphasis_ (block)</td></tr>
</table>
## More complicated
<table>
<tr><td markdown="1">
* this is _not_ a list item</td></tr>
<tr><td markdown="span">
* this is _not_ a list item</td></tr>
<tr><td markdown="block">
* this _is_ a list item
</td></tr>
</table>
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)