#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(<XMLname\s*.*ipcode=").*?(".*)$"
Local $sString = "<XMLname attribute=value ipcode="ee " & @CRLF & _
"ec" " & @CRLF & _
"" & @CRLF & _
"attribute='value'>CDAT! dfg abc="ddd" <name>< attribute=value ipcode="value" " & @CRLF & _
" attribute='value'></name>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")