$re = '/(?s)(<XMLname\s*.*ipcode=").*?(".*)$/m';
$str = '<XMLname attribute=value ipcode="ee
ec"
attribute=\'value\'>CDAT! dfg abc="ddd" <name>< attribute=value ipcode="value"
attribute=\'value\'></name>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);