import re
regex = re.compile(r"(?s)(<XMLname\s*.*ipcode=\").*?(\".*)$", flags=re.MULTILINE)
test_str = ("<XMLname attribute=value ipcode=\"ee \n"
"ec\" \n\n"
"attribute='value'>CDAT! dfg abc=\"ddd\" <name>< attribute=value ipcode=\"value\" \n"
" attribute='value'></name>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")