package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)jform\[([\w\-]+)\]\[?([\w\-]+)?\]?`)
var str = `jform[eqF-Weqwe][csdf_332]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}