$re = '/jform\[([\w\-]+)\]\[?([\w\-]+)?\]?/m';
$str = 'jform[eqF-Weqwe][csdf_332]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);