#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[/=])(?<!version=)\d+"
Local $sString = "https://app.url.com/user-guide/1234567" & @CRLF & _
"" & @CRLF & _
"https://api.url.com/usage-logging/v1/log/analytics-multi/no-auth?clientSendTimestamp=1622719272795&portalId=863256543&clienttimeout=14000&hs_static_app=automation-ui-index&hs_static_app_version=1.3520"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")