const regex = new RegExp('(?<=[/=])(?<!version=)\\d+', 'gm')
const str = `https://app.url.com/user-guide/1234567
https://api.url.com/usage-logging/v1/log/analytics-multi/no-auth?clientSendTimestamp=1622719272795&portalId=863256543&clienttimeout=14000&hs_static_app=automation-ui-index&hs_static_app_version=1.3520`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}