$re = '`(?<=[/=])(?<!version=)\d+`m';
$str = 'https://app.url.com/user-guide/1234567
https://api.url.com/usage-logging/v1/log/analytics-multi/no-auth?clientSendTimestamp=1622719272795&portalId=863256543&clienttimeout=14000&hs_static_app=automation-ui-index&hs_static_app_version=1.3520';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);