using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Two and (?<=and )Person";
string input = @"By Person One, Person Two and Person Three";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}