$re = '/Two and (?<=and )Person/m';
$str = 'By Person One, Person Two and Person Three';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);