$re = '/(?:latitude=(?<lat>-?(?:\d+\.)?\d+)|longitude=(?<lng>-?(?:\d+\.)?\d+))/';
$str = 'https://media.rightmove.co.uk/map/_generate?width=761&height=347&zoomLevel=15&latitude=51.068509&longitude=-1.800635&signature=_JzeV8INWTON89M3-vFPvRUP-Pc=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);