import Foundation
let pattern = #"(?:latitude=(?<lat>-?(?:\d+\.)?\d+)|longitude=(?<lng>-?(?:\d+\.)?\d+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://media.rightmove.co.uk/map/_generate?width=761&height=347&zoomLevel=15&latitude=51.068509&longitude=-1.800635&signature=_JzeV8INWTON89M3-vFPvRUP-Pc="#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)