// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:latitude=(?<lat>-?(?:\d+\.)?\d+)|longitude=(?<lng>-?(?:\d+\.)?\d+))").unwrap();
let string = "https://media.rightmove.co.uk/map/_generate?width=761&height=347&zoomLevel=15&latitude=51.068509&longitude=-1.800635&signature=_JzeV8INWTON89M3-vFPvRUP-Pc=";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}