import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SEARCH\\s*\\|\\s*(\\S.*)";
final String string = "2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Humana\n"
+ "2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Car\n"
+ "2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Phone 12 pro\n"
+ "2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Humana papa ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}