const regex = new RegExp('SEARCH\\s*\\|\\s*(\\S.*)', 'gm')
const str = `2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Humana
2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Car
2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Phone 12 pro
2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Humana papa `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}