import re
regex = re.compile(r"SEARCH\s*\|\s*(\S.*)", flags=re.MULTILINE)
test_str = ("2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Humana\n"
"2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Car\n"
"2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Phone 12 pro\n"
"2022-06-29 12:45:04.652 | INFO | product.views.product_view:list:28 - SEARCH | Humana papa ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")