using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^\/]+\/){4}\K(?:[^_]+_){3}[^_]+";
string input = @"path/to/the/file/text_I_want_tokeep_loremipsumdolorsitamet";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}