$re = '/^(?:[^\/]+\/){4}\K(?:[^_]+_){3}[^_]+/';
$str = 'path/to/the/file/text_I_want_tokeep_loremipsumdolorsitamet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);