package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?\d+(?:,-?\d+)*$`)
var str = `1,2,3
-1,2,-3
3
4
22,-33
1,,2
--1,2,3
-1,2,--3
asdas
[]\%$1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}