import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?\\d+(?:,-?\\d+)*$";
final String string = "1,2,3\n"
+ "-1,2,-3\n"
+ "3\n"
+ "4\n"
+ "22,-33\n\n"
+ "1,,2\n"
+ "--1,2,3\n"
+ "-1,2,--3\n"
+ "asdas\n"
+ "[]\\%$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}