re = /^-?\d+(?:,-?\d+)*$/m
str = '1,2,3
-1,2,-3
3
4
22,-33
1,,2
--1,2,3
-1,2,--3
asdas
[]\\%$1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end