#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:\B-)?\d+,?)+\b$"
Local $sString = "1,2,3" & @CRLF & _
"-1,2,-3" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"22,-33" & @CRLF & _
"" & @CRLF & _
"1-2-3" & @CRLF & _
"" & @CRLF & _
"1,,2" & @CRLF & _
"--1,2,3" & @CRLF & _
"-1,2,--3" & @CRLF & _
"asdas" & @CRLF & _
"[]\%$1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")