$re = '/^(?:(?:\B-)?\d+,?)+\b$/m';
$str = '1,2,3
-1,2,-3
3
4
22,-33
1-2-3
1,,2
--1,2,3
-1,2,--3
asdas
[]\\%$1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);