// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:\B-)?\d+,?)+\b$").unwrap();
let string = "1,2,3
-1,2,-3
3
4
22,-33
1-2-3
1,,2
--1,2,3
-1,2,--3
asdas
[]\\%$1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}