using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"U=(?<mfcsrc>\d{6})\sP=(?<mfcprio>\d)\sZ=(?<mfcdst>\d{6}),\sWW=(?<mfcWW>\d*),\sL=(?<mfcline>.*)\sB=(?<mfctrunk>.*)\sD=(?<mfcdur>\d\d:\d\d)\sE:(?<mfcCC>.*),CC=(?<mfcCCC>.*),\sName=(?<LOWW_IF>.*),\sAddress=(?<vcsNODE>.{5});";
string input = @"SWT KIS VCS Stat;08.09.2018 22:33:36;;U=366570 P=2 Z=362850, WW=0, L=braswt 0501 B=BRA TRIANGLE D=00:19 E:Internal user,CC=End by Internal User, Name=PHIF_10, Address=302E0;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}