const regex = /U=(?<mfcsrc>\d{6})\sP=(?<mfcprio>\d)\sZ=(?<mfcdst>\d{6}),\sWW=(?<mfcWW>\d*),\sL=(?<mfcline>.*)\sB=(?<mfctrunk>.*)\sD=(?<mfcdur>\d\d:\d\d)\sE:(?<mfcCC>.*),CC=(?<mfcCCC>.*),\sName=(?<LOWW_IF>.*),\sAddress=(?<vcsNODE>.{5});/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('U=(?<mfcsrc>\\d{6})\\sP=(?<mfcprio>\\d)\\sZ=(?<mfcdst>\\d{6}),\\sWW=(?<mfcWW>\\d*),\\sL=(?<mfcline>.*)\\sB=(?<mfctrunk>.*)\\sD=(?<mfcdur>\\d\\d:\\d\\d)\\sE:(?<mfcCC>.*),CC=(?<mfcCCC>.*),\\sName=(?<LOWW_IF>.*),\\sAddress=(?<vcsNODE>.{5});', 'g')
const str = `SWT KIS VCS Stat;08.09.2018 22:33:36;;U=366570 P=2 Z=362850, WW=0, L=braswt 0501 B=BRA TRIANGLE D=00:19 E:Internal user,CC=End by Internal User, Name=PHIF_10, Address=302E0;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}