using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:--(?:help|version)|-(?:h\W|v\W))|(?:--?\w+:\w+)";
string input = @"-h
-help
-v
-version
--help
--version
-mail:moo
--mailer:mm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}