re = /(?:--(?:help|version)|-(?:h\W|v\W))|(?:--?\w+:\w+)/m
str = '-h
-help
-v
-version
--help
--version
-mail:moo
--mailer:mm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end